[Opm] Greetings & compile questions

Richard Huntrods huntrods at athabascau.ca
Thu Jul 14 04:02:21 UTC 2016

Hi Liu,

On 7/13/2016 6:59 PM, Ming Liu wrote:
> Hi Richard,
> If I understand you  correctly, you have already been built and run 
> FLOW, that means you don't have any issue related to the compile and 
> linker.
> The only issue is that when you running flow, some messages are output 
> in the terminal saying that
> "
> Error: Keyword 'NOECHO' is not supported by flow.
> In file /home/liuming/work/opm/opm-data/norne/NORNE_ATW2013.DATA, line 
> 143
> Error: Keyword 'SPECGRID' is not supported by flow.
> In file 
> /home/liuming/work/opm/opm-data/norne/INCLUDE/GRID/IRAP_1005.GRDECL, 
> line 10
> "
> But after these keywords, flow is still running, right?
Correct. The SPE 1 & 3 case as well as Norne all ran to completion and 
gave the same output as 14.04.
> Probably the confused thing is that these kinds of messages did not 
> show before, that's because we introduce these messages early this 
> week,  that is this PR https://github.com/OPM/opm-simulators/pull/756.
OK. That makes sense. My build of flow on Ubuntu 14.04 was done July 7 
15:54 PDT. (I just checked the dates on /usr/local/bin.

That would mean that if I were to build flow again on ubuntu 14.04 
(using the latest code) I would see the same error messages when I run 
cases. That's good to know. I'll probably do that this week. :-)
> But regarding ubuntu 16.04, there is a potential issue could lead to 
> the failure of the build process, please check  issue here 
> https://github.com/OPM/opm-simulators/issues/757


My most recent build on ubuntu 16.04 today, trying to use the latest 
libraries was even worse. Flow did not compile (fatal compile errors).  
Checking my dependencies script, I see that  I did install the latest 
libeigen, which the issue states does not work.

This is very enjoyable for me. I'm also working to convert some of my 
very old datasets from other simulators to the Eclipse 100 deck format. 
I do wish there was a pdf copy of the Eclipse manual around. I looked 
but there's only course notes and such, unless I've missed something.

Seeing the issues you highlighted, I think I'll sign up to join the 
github conversations tomorrow.


> Best regards,
> Liu Ming
> 2016-07-14 9:45 GMT+08:00 Richard Huntrods <huntrods at athabascau.ca 
> <mailto:huntrods at athabascau.ca>>:
>     Hi Liu,
>     I understand.
>     I'm not talking about Eclipse keywords that are not in the Ubuntu
>     14.04 version today.   I am talking about keywords that work today
>     in flow compiled on ubuntu 14.04 but are missing when you compile
>     the same exact source code in Ubuntu 16.04.  Keywords like ECHO
>     and NOECHO.
>     Something in the ubuntu 16.04 build process isn't compiling or
>     linking everything correctly. I am currently diggin deeper to see
>     which dependencies have changed between 14.04 and 16.04.
>     I do know there's an issue with libtool. It's not installed by
>     default in Ubuntu 16.04 but was in Ubunty 14.04. Worse, when you
>     install it in 16.04, somehow it's not where Cmake wants it to be,
>     which I am sure is affecting the build / link process. I'm
>     tracking that down.
>     There are also different (newer) versions of dependencies between
>     ubuntu 14.04 and ubuntu 16.04:
>       libumfpack5.6.2 (now libumfpack5.7.1 in ubuntu 16.04)
>       libboost1.55-dev-all (now libboost1.58-dev-all in ubuntu 16.04)
>       and  libsuperlu3-dev (now libsuperlu-dev in ubuntu 16.04)
>       Finally, C++ is installed by default in Ubuntu 16.04 at version
>     5, not 4.7.
>     The problem for me is that it's a very complex build process, and
>     trying to figure out which new dependency library is causing the
>     compile process to hiccup is difficult. However, I'm working away
>     at it.
>     Cheers,
>     -Richard
>     On 7/13/2016 5:59 PM, Ming Liu wrote:
>>     Hi Richard,
>>     I think what kai said is very clear, recently we are working on
>>     the improvement of the print file, that is .PRT file,  we believe
>>     this will give the user clear messages that some keywords are not
>>     supported by flow currently, that's why you can see lots of
>>     output.  I'm sorry this output brings you the trouble, but do not
>>     worry, nothing changed in the source code about summary file and
>>     restart file, you can still check results with any visualization
>>     tools you like, such as resinsight.
>>     Best regards,
>>     Liu Ming
>>     2016-07-14 0:16 GMT+08:00 Richard Huntrods
>>     <huntrods at athabascau.ca <mailto:huntrods at athabascau.ca>>:
>>         Greetings!
>>         My name is Richard Huntrods, currently on Vancouver Island
>>         Canada. My background is in Chemical Engineering (B.Sc. &
>>         M.Eng.). I spent 5+ years in the 1980's writing reservoir
>>         simulators for a few companies in Alberta, Canada. Since then
>>         I moved into consulting, then full-time teaching. I'm
>>         currently teaching Computer Science at Athabasca University -
>>         a distance education university in Alberta.
>>         I have always been interested in reservoir simulation, and
>>         recently have begun compiling and using the FLOW simulator
>>         from the OPM project.
>>         I have successfully compiled and used the OPM suite on Ubuntu
>>         14.04 as per the build guidelines. I also have kept detailed
>>         notes of my process, from starting VirtualBox on a Windows 7
>>         PC through installing Ubuntu 14.04 and then obtaining and
>>         building the OPM sources. I also wrote a few shell scripts to
>>         help automate the process and have confirmed it a few times
>>         with clean builds.
>>         I would be willing to share my documents and scripts if desired.
>>         I'm now in the process of building OPM from source on Ubuntu
>>         16.04. I *almost* works. With a few minor changes required in
>>         dependency packages, I have been able to get all the sources 
>>         compiled and running. However, there's a problem with FLOW -
>>         it won't recognize many of the output keywords such as ECHO,
>>         NOECHO, RPTSCHED from the SPE test cases, and many more in
>>         the Norne test case. I am sure it's a missing dependency in
>>         the Eclipse input code, but have not yet isolated it.
>>         I am wondering who is currently working on compiling under
>>         Ubuntu 16.04 and whether or not they would be willing to
>>         share any tips and problems they may already have seen and
>>         diagnosed. I'd be very willing to contribute to this process.
>>         Thanks in advance, and again welcome to everyone.
>>         -Richard Huntrods, P.Eng.
>>         ---
>>         This email has been checked for viruses by Avast antivirus
>>         software.
>>         https://www.avast.com/antivirus
>>         _______________________________________________
>>         Opm mailing list
>>         Opm at opm-project.org <mailto:Opm at opm-project.org>
>>         http://opm-project.org/cgi-bin/mailman/listinfo/opm
>     <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>
>     	Virus-free. www.avast.com
>     <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

This email has been checked for viruses by Avast antivirus software.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <//opm-project.org/pipermail/opm/attachments/20160713/87943e8b/attachment.html>

More information about the Opm mailing list